Sega Model 2A garbage screen

Qui trovi aiuto nella risoluzione dei problemi hardware del tuo cabinato
Rispondi
skylab
Gamer
Gamer
Messaggi: 49
Iscritto il: 18/05/2017, 14:46
Reputation: 1

Sega Model 2A garbage screen

Messaggio da skylab » 14/07/2017, 17:55

Ciao a tutti. Ho recuperato una model 2A con gioco Dead or alive, la scheda è composta da video board, cpu board, rom board, security board e filter board. Visivamente è in buone condizioni, l’ho collegata ma il gioco non si avvia, si vede solo un “garbage screen”.
Per alimentarla ho usato un alimentatore atx, le tensioni sono ok, ho provato anche con altri alimentatori.
Appena do corrente si vedono i 4 led sulla video board accendersi e spegnersi subito dopo, mentre sulla cpu board si accende e rimane acceso solo il led 11. Non esce nessun suono dai canali audio, quindi non è solo la grafica a non funzionare ma la scheda risulta proprio frezata.
Il garbage screen non è sempre uguale ma varia leggermente di volta in volta.
Per collegarla allo schermo lcd ho usato un convertitore che naturalmente funziona dato che lo uso con le schede jamma a 15khz e supporta anche i 24khz.
Ho letto su un forum di un tizio con lo stesso problema, garbage screen e stessa sequenza coi led, ha risolto scollegando e ricollegando le schede tra loro. Ho provato più volte ma niente, ho anche verificato i collegamenti che sembrano ok.
La security board scalda parecchio non so se sia normale.
Ho provato anche senza la security board per capire se potesse dipendere da lei ma fa la stessa identica cosa. Stessa cosa senza rom board.
Suppongo che senza security board e/o rom board dovrei vedere qualche messaggio di errore o schermo nero, quindi suppongo il problema sia o nella cpu board o nella video board. Correggetemi se sbaglio.
Sono state rifatte le saldature delle gpu marchiate 315-5646 e 315-5647 in quanto sono gli unici chip a presentare residui di flussante.
Spero ci sia tra voi qualche esperto di model 2 che mi possa aiutare. [help2.gif]
20160927_164132.jpg
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.




skylab
Gamer
Gamer
Messaggi: 49
Iscritto il: 18/05/2017, 14:46
Reputation: 1

Re: Sega Model 2A garbage screen

Messaggio da skylab » 19/11/2018, 18:00

Buongiorno ragazzi! Ho delle novità: il problema risiede da qualche parte nella cpu board, c'è il clock sul i960 ma non c'è attività sul bus. Dato che non posso testare ram e cpu i960 ho verificato tutte le piste e sono ok, le ho seguite fino alla rom board.
A questo punto l'unica cosa che posso testare sono le eprom e finalmente ho trovato qualcosa che non va. Ho letto le rom che contengono il software della cpu ma ottengo dei crc che non coincidono con quelli del mame. Ho provato più volte, ho pulito per bene i pin ma niente ottengo sempre gli stessi crc che però sono diversi. Ho provato allora a leggere la rom della cpu audio e questa invece coincide col mame.
C'è però una differenza: la rom audio è marchiata epr-19328 come nei sorgenti del mame mentre le altre nei sorgenti del mame hanno una "a" in più: epr-19310a e epr-19311a sul mame, mentre le mie sono epr-19310 ed epr-19311.
Inoltre i sorgenti riportano id rom board 834-11342 mentre la mia è 834-11342 B. Ho pensato potesse essere un'altra versione ed ho quindi sostituito i file appena dumputi nel mame ed avviato il gioco (vengono rilevati i crc errati ma si può skippare) ma crasha restituendo il seguente errore: fatal error: i960: 634: unhandled ff.
Naturalmente non ho potuto fare la prova contraria dato che mi serve una lampada per azzerare le eprom.
Prima di azzerarle però vorrei capire se effetivamente le rom non sono buone oppure è una versione non dumpata.
I crc sono:
epr-19310 CRC(3c571e75)
epr-19311 CRC(8818363d)


Rispondi